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1. Introduction 
 

3DOM (Free Datalogger Oriented Manager) is the program used to configure the LSI LASTEM 

acquisition instruments of AlphaLog, Aliem, Pluvi-ONE, E-Log, R-Log, M-Log, S-Log and X-Log 

families. This program allows: 

 

• To set up and modify the instruments configurations; 

• To send and receive the configurations through different connection types; 

• To export and import configurations between different instruments; 

• To set up the instrument’s clock and verify the operating statistics (*); 

• To verify the measures’ values updated inside the instrument in every moment (*); 

• To configure the data save options (*); 

• To download and save the data processed by the instruments (*). 
 

(*) Some features are not available for all instruments. 
 

2. System Requirements  
 

The program needs following software requirements: 
 

• Operating system Microsoft Windows from Microsoft Windows 7 (*) 

• Microsoft .NET Framework 3.5 (**); 

 

(*) Operating systems must be updated with the latest update released by Microsoft and 

available through Windows Update. 

(**)Starting from Windows 8 you can enable. NET Framework 3.5 manually from the Control 

Panel . In the Control Panel  you can use Add Programs and Features , then  Enable or disable 

Windows features  and then select the check box  Microsoft. NET Framework. This option requires 

an Internet connection. 
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3. Installation 
 

First of all verify the required system’s requirements. It’s needed to run the setup as administrator; 

at the opposite the installation will be non-correct. 

 

3.1. Modify the program’s language   
 

If the language of computer’s operating system is in Italian, the program use the Italian language; if 

the language of computer’s operating system isn’t in Italian, 3DOM make use of English language.  

If the user wants to force the use the Italian or English language, whatever the operating system’s 

language, it is necessary open with a text’s editor (ex. Notepad) the file “LSI.3Dom.exe.config” in 

the installation folder and modify the following setting: 

 
            <setting name="UserDefinedCulture" serializeAs="String"> 

            <value>en-us</value> 

 

The value <value>en-us</value> set the program to use the English language, the value 

<value>it-it</value> set the program to use the Italian language. 

 

WARNING 

If the text’s editor does not allow saving the file after the change is necessary to restart the text’s 

editor as administrator. 
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4. Description and use of the program 
 

4.1. Main Window 
 

Main window as below: 

 

 
 

 

• Instruments Browser: it shows the instruments configured in the local computer, subdivided 

according to the different typologies and written according to their serial number;  

• Data Logger Properties: it shows the personal data of the selected instrument;  

• Configurations: it  shows the configuration files list associated with the selected instrument;  

if the instrument has been configured correctly, the operating configuration is shown in the 

state “On Instrument” and icon ; the right lower panel shows the status of the last 

processed data download (referred to selected instrument) and the date of the last one 

correctly downloaded; in case of errors it shows their description; 

• Data Storage Configuration: it shows the data storages used to save the elaborated data 

download. 

• The status bar shows the selected instrument, the selected configuration and the operating 

mode; 

• Selecting one typology of instruments in the panel Instruments, you can see in the right 

panel the download status of all these instruments configured in the PC. 

 

It’s possible that program looks different because the position of these windows can be modified: 

• If window shows the icon  in the title bar, the window is always visible; if it shows the 

icon  it  means that the window hides itself automatically when it isn’t selected, and 

shows only a label anchored to the border of main window. In order to restore the window 

click mouse on this label. 
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In order to modify the look of display icon click on it.  

 

• It’s possible to close the data logger configuration windows; to show this windows again 

select the menu Options → Data Storage Configuration. 

• It’s possible move the windows and anchor them in other positions of the display dragging 

them by title bar: during dragging the possible new anchorage positions are displayed. 

 

 
 

 

The program has got: one menu to start all available facilities, and one keys bar to display the main 

facilities. Two keys Configuration and Communication allow the selection of the keys displayed in 

the keys bar and cluster them according to their function. 
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4.1.1. Structure of the menus 

 

The program has got one main menu and several contextual menus which auto-configure 

themselves according to the selected element. 

 

 
 

The main menu consists of the following elements: 

 

• File: 

o Import Binary Data: imports data downloaded from the mobile device or from 3DOM 

on storage media BinaryFile 

o Exit: it allows the exit. 

 

• View: 

o Refresh: to update contents of all included panels; 

o Order by Factory Serial Number: sorts the list of the instruments according to their 

serial number; 

o Order by User Serial Number: sorts the list of the instruments according to their name 

(or number) set up by the user; 

o Order by Description: sorts the instruments according to their description; 

o Error Code Visualizer: shows the window that displays the detailed description of the 

error codes according to the numerical code supplied by the instrument; 

o Reset windows layout: arranges the windows according to the standard configuration. 

 

• Instrument: 

o New: inputs a new instrument; 

o Delete: removes the selected instrument; 

o Communication Parameters: configures the communication parameters of the selected 

instrument; 
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o Change Description and User Serial Number: modifies the name (or the number)  and 

the description supplied by the user to the selected instrument; 

o Export: exports all the configurations, the calibration data and the communication 

parameters of the selected instrument; 

o Import: imports the configurations of one instrument, exported previously ; 

o Find Instrument: run find serial port connected instrument utility (ref. §5). 

 

• Configuration: 

o New: sets up new configuration for the selected instrument; 

o Edit: modifies the selected configuration; 

o Load from USB drive: loads a configuration saved on a USB stick, available only for 

Alpha-Log instruments 

o Rename: renames the selected configuration; 

o Delete: deletes the selected configuration; 

o Save as new configuration: saves the selected configuration with new name; 

o Save  as new  template: saves the selected configuration like a new model; it can be used 

to set up new configurations for other instruments; 

o Download: sends the selected configuration to the instrument ; 

o Upload: receives the configuration of the selected instrument; 

o Upload probes library: updates the sensors library according with the latest firmware.  

 

• Communication: 

o Registry: receives the personal data of the selected instrument;    

o Statistics: displays the statistics of the selected instrument; 

o State: displays the operating status of the selected instrument; 

o Instantaneous Values: displays the instantaneous values of the selected instrument ; 

o Elaborated Values: receives the processed data included in the selected instrument and 

saves them into the different configured mediums (ref. §4.6.2). 

o HangUp modem: disconnects the modem is it’s on. 

 

• Options: 

o Data storage configuration: sets up the properties of the different files available for the 

save of the processed data. 

o License manager: it shows the license manager program. 

o Report program configuration: sets the default program for viewing reports of the 

instrument configurations 

 

• Help: 

o User’s manual: displays this manual; 

o Check for updates: checks the availability of updating for the program ; 

o E-Log quick start: quick start for E-Log instruments; 

o R-Log quick start: quick start for R-Log instruments; 

o M-Log quick start: quick start for M-Log instruments; 

o S-Log quick start: quick start for S-Log instruments; 

o Pluvi-ONE quick start: quick start for Pluvi-ONE instruments; 

o AlphaLog quick start: quick start for AlphaLog instruments; 

o ALIEM quick start: quick start for ALIEM instruments; 

o About: shows the general information about the program. 

o About library: shows version of the library files used by the program. 
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4.2. Set up a new instrument 
 

This is the first operation to execute after the installation of the program. Every instrument operates 

with own configuration’s file, that includes different information (including the list of the used 

sensors and their acquired logics). The configuration of every instrument is made at time of 

manufacturing, using one standard configuration file. Download the standard file from the 

instrument to modify its information; if it isn’t possible to receive the file from the instrument, it 

can be required the LSI LASTEM. When the standard file is on PC, it can be copied and modified, 

and then sent to the instrument. The instrument will start to operate with new configuration. 

 

It’s possible to input new instrument by means of the configurations set-up procedure of the 

instrument, from menu Instrument -> Import (ref. §4.4.10). In this way the instrument’s 

configurations can be copied from one PC to the others, in case they need to dialogue or to manage 

the instrument’s data. 

 

To set up a new instrument select Instrument->New. It starts the guided routine for the input of new 

instrument. The procedure proposes a preliminary choice that distinguishes between: 

 

• E-Log, R/M-Log, S-Log, ALIEM, X-Log, R-Comm instrument 

• AlphaLog, Pluvi-ONE instrument 

 

4.2.1. Input of new E-Log, R/M-Log, ALIEM, S-Log 

instrument  

 

To input new instrument of these types connected to the PC, in the text box of the first screen of the 

guided routine, DO NOT select Insert a new data logger importing an existing calibration file. 

 

In the next screens specify or input the base parameters for communication: for serial 

communications verify in particular the serial port and speed of communication which by default is 

9600 for E-Log and 57,600 for other instruments. 

 

If the wizard is able to communicate with the instrument it displays the serial number, the name 

supplied by the user and the description of the instrument; if needed change these two parameters. 

 

At the end of the input procedure the program tries to dialogue with the instrument directly, in order 

to download the calibration data and the running operating configuration. In case the 

communication isn’t able to end this operation, the instrument is not added to the program.  

 

If the user has got the calibration file supplied by LSI LASTEM (referred to the serial number of the 

device), it’s possible to set-up the new instrument into the program following this procedure 

selecting in the opening screen of the guided routine the text box Insert new data logger importing 

an existing calibration file and specify or input the calibration file that has to be imported; the 

wizard continues as described above. 

 

After the input procedure, the program tries to communicate with the instrument directly, in order to 

download the remaining configuration data; it doesn’t change the calibration data specified by the 

file at the beginning of the procedure. In case of communication error, it’s possible to set-up one 

new configuration (from one model or from zero), because the PC contains the instrument’s 

calibration data. 
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Warning 

The imported calibration file has NOT to be situated into the folder: 

 

Windows XP: 

 C:\Documents and Settings\All Users\Dati applicazioni\LSI-Lastem\Sltn2\[TYPE]\config,  

 

Windows Vista or Seven 

C:\Program Data\LSI-Lastem\Sltn2\[TYPE]\config, 

 

where [TYPE] is the instrument type (E-Log, R-Log …). 

 

4.2.2. Input of new AlphaLog, Pluvi-ONE instrument  

 

To insert a new instrument of these types, it is necessary to enter the serial number and the 

instrument password provided by LSI LASTEM. 

In the next screen, specify the communication parameters with the instrument that require the use of 

the SSH protocol to communicate directly with the instrument, or the use of an FTP server used by 

the instrument as configuration authority (see the manual of the instrument); in this case the 

communication (sending / receiving the configuration) does not take place directly with the 

instrument but with the FTP area. 

 

 
 

Once the communication parameters have been specified, the program tries to connect to the 

instrument and in case of success it downloads the configuration. 
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4.3. Configure the communication 
 

To modify the communication parameters of the selected instrument, select the menu Instrument-

>Edit Communication Parameters. 

 

4.3.1. E-Log, R/M-Log, S-Log, ALIEM, R-Comm Instruments 

 

 
 

In order to communicate with the instrument, the program can use following devices:  

 

• Serial: the program uses the specified serial port (installed on the PC) also through USB 

adapters, or the virtually configured serial port  (if used protocol’s devices conversion); 
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• Modem: the program uses the specified phone modem; it has to be already configured into 

the operative system using the procedure from the Windows control panel; 

• Protocol TCP: it’s possible to specify the use of one device serial server that arranges the 

protocol transfer from TCP to RS232/485 serial line, at which the instrument is connected. 

 

Selecting the controls, it’s possible to display a brief informative text. 

 

4.3.2. AlphaLog, Pluvi-ONE Instruments 

 

 
 

The program can communicate with the instrument using the SSH protocol or by connecting to an 

FTP area considered by the instrument as configuration authority; in this case the communication 

will not take place directly with the instrument but only with the FTP area. 

Selecting the controls, it’s possible to display a brief informative text. 
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4.4. Operate with the configurations 
 

Every instrument operates according to the supplied operating parameters. To configure one 

instrument, it needs: 

 

1. Select the desired instrument from the instruments’ panel; 

2. Set-up one new configuration or modify the old one; 

3. Send the modified configuration to the instrument. 

 

For the first configuration of one instrument not included into the instruments’ list, input the new 

instrument (ref § 4.2). 

 

It’s possible to set up all the requested configurations for each instrument. The configuration 

displayed in the configuration’s list with icon  is the last configuration sent to the instrument. 

 

Warning 

If other PC communicate with the same instrument, the locally configuration can be the 

current configuration not any more. To verify it, arrange as follow: try to download the 

configuration from the instrument; if the instrument’s configuration corresponds to the 

locally specified configuration, the program will advise that the current configuration is 

already present. 

 

4.4.1. Set up a new configuration 

 

Select the menu Configuration -> New, or the key New  from the keys bar Configuration. It shows a 

window with some available configuration models: these models include configuration parameters 

already prepared. It’s possible to select one model and modify it according to the user’s needs. The 

program shows for every selected model a brief description. 

 

Select the required model and press Ok key to set-up a new configuration (based on selected 

model). Before the save of the file, input the code that marks the different configurations. 

 

The LSI LASTEM supplies the base models; the users can input new personalized models (ref. 

§4.4.3). 

4.4.1.1. Configuration description 

 

Each configuration is associated with a name, code and description. The code is the model identifier 

from which you created the configuration and is intended for internal use (§ 4.4.2).   

To change the configuration description select the configuration and then the menu Configuration-

>Change configuration description or the menu Change configuration description on selected 

configuration: 
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The field “Code” is not enabled because this value is used internally by other programs LSI 

LASTEM (§ 4.4.2).  

4.4.2. Special models 

 

Some models are supplied by LSI LASTEM for general use, others are configured to perform 

specific calculations such as those of the thermal environment. These templates contain all 

necessary measures for the specific type of calculation for which the model was created. 

These models are identified by special codes used by other programs LSI LASTEM to 

automatically locate the most suitable configuration. 

When you edit a configuration created from a special model, the user is warned that the removal of 

a measure on the configuration makes it inconsistent for the type of calculation for which it was 

originally created: if you continue maintaining the changes you made, the identifier code is 

removed from the configuration. 

The icons of the configurations created from special models are slightly different from those of the 

configurations created by normal templates (configuration  last configuration sent to the 

instrument ). 

4.4.3. Set-up new model from existing configuration  

 

It’s possible input a new model into the configuration models’ list, making reference to an existing 

configuration. 

 

To set-up a new model from an existing configuration, select the configuration and then the menu 

Configuration->Save as new configuration or the menu Save as new configuration on selected 

configuration. Save the configuration like a model, and it’ll be included in the models list. 

 

Warning 

The new model can be used for all instruments compatible with the configuration used for the 

set-up of the model.  

4.4.4. Modify one configuration 

 

To modify one configuration select it from the program’s main window and then select the menu 

Configuration->Edit or the key Edit on the keys’ bar Configuration or the menu Edit Configuration 

on the configuration that user needs modify. 
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This window allows the modification of all parameters of the selected configuration, according to 

the type and the version of the selected instrument. 

 

 
(window for the modifications of E-Log configuration) 
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(window for the modifications of R-Log configuration) 
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(window for the modifications of Pluvi-ONE configuration) 

 

 

The window’s left area shows different main sections according to the instrument’s type and 

version: select one item to show and edit the corresponding parameters. 

 

Press the Save button to save the modifications, the Cancel button  to close the modification phase 

without the save of the modifications, the Check button to check the inputted modifications and the 

Check Data Structure button to check the modification at the data structure of the configuration and 

the Report button to create a report of the configuration (§ 4.4.5). 

 

4.4.4.1. Maintaining the data compatibility 

Since version 3.6.0.0 of the program 3DOM you can change the configuration and send it to the 

instrument without erasing the data stored in memory and without interrupting the continuity of data 

stored in the database GIDAS provided it has not been altered the structure of elaborated data stored 

by the instrument. To preserve the structure of data stored by the instrument is necessary to avoid: 

 

• add or delete or move measures; 

• for each measure to change the type of measure, its properties or elaboration types; 

• change the elaboration rate. 

 

All other configuration changes maintain data integrity. To test whether the changes made did not 

alter the integrity of the data using the Check Data Structure button. 

If data integrity is maintained when the configuration is saved the program does not affect the date 

of the configuration, but only the date of the file that contains it. When the configuration is sent to 

the instrument data in memory and the structure of the data is not modified, so the data stored in the 

database GIDAS maintain their continuity. 

 

 
 

In this example, the current configuration of the instrument 09040643 has the data structure updated 

on October 27 while the configuration was changed the next day: the elaborated data stored in 

GIDAS database after modifications of  October 28 will be appended to the data stored before and 

the GIDAS database will display only one configuration dated on October  27. 

 

4.4.4.2. Configuration checking 

If the configuration contains some errors, it displays the list of the errors or of the attention 

messages. This happens during save (or pressing the key Check). 

 

• If the check displays only attention messages, it’s possible continue the save (however not 

recommended);  

• If the check displays error messages, it ISN’T  possible continue the save of the 

configuration without the previous correction of the wrong or not compatible parameters.  
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For E-Log, R/M-Log, S-Log, ALIEM instruments before saving the configuration 3DOM displays 

the measures sorting window before the final save of the configuration; in this window it’s possible 

modify the sorting of the measures.  

This is very important, because the instrument acquires and calculates the measures according to the 

reported sorting; therefore sort as near as possible the measures to sort together (the direction and 

the speed of the win typically). The instrument displays the measures according to this sorting. 

 

  
 

(sort window for E-Log version on the left, for R-Log version on the right) 

  

Note 

E-Log version 1.x does not support serial measures. 

 

Warning 

If the modified configuration is used like current configuration, it is necessary to send it to the 

instrument again, to configure the instrument. If the user want modify the current configuration, 

but not modify the instrument configuration, he has to save the configuration with different 

name before he modifies it (menu Configuration->Save as new configuration), and then modify 

the configuration with the new name. 

 

4.4.5. Configuration Report  

 

Pressing the Report button at the top of the window of configuration edit, is generated and 

displayed the configuration report. 

 

The report contains all the configuration information for configuring the instrument; it also shows 

how to connect the various acquired probes at the instrument terminal blocks if required by the type 

of instrument. 

 

Warning 

The visualization of the connections with the instrument terminals is available only if the 

measures in the configuration are created by using the sensors library built into the program; 

configurations already created before the program release version 3.6.1 may not show all 

information. 

 

The configuration report is created using the docx format (Office Open XML). The standard Office 

Open XML (ECMA-376) format is supported by: 
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• Word 2007 and superior version; 

• WordPad in Windows 7 (free application available in Windows 7) 

• Word 2000 and above with installing the compatibility pack; 

• OpenOffice 3.2; 

• SoftMaker Office or the free version (Viewer) TextMaker (5MB). 

 

If your computer does not have a program that could read docx files, by selecting the menu Options 

Configuration Report Program opens the configuration window for the selection of a program to 

associate with the docx file. 

 

 
 

4.4.6. Configuration of E-Log, R/M-Log, S-Log, ALIEM 

 

The following pages briefly describe the modification of the configuration E-Log, R / M-Log, S-

Log, ALIEM instruments. Depending on the type of instrument, some options may not be available. 

 

4.4.6.1. Modification of the measures 

 

There are for ways for input of new measures inside one configuration:  

1. input of measures using the library of LSI LASTEM sensors (see §4.4.6.2); 
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2. input of measures (not included in the library) using one pre-configured model (see 

§4.4.6.3); 

3. input of new measures not included in the library (see §4.4.6.4). 

4. import measures from the configuration of another instrument (see §4.4.6.6) 
 

Selecting Measures from the panel General Parameters  it displays the panel that includes the 

parameters for the management of the measures: 
 

 
(E-Log  configuration) 

 

The list shows measures configured inside the instrument. For every configured measure it’s 

displayed: the position, the name, input, update, processing types, and the list of the dependent 

measures (in case of calculated measures). 

 

Every measure has got its icon: 
 

• Acquired measure ; 

• Serial sensor :  it uses both network channel and address (Protocol Id); 

• Calculated measure: . 

 

The icon is modified when one calculated measure uses one measure: , ,  

 

Warning 

It’s possible the input of several calculated measures (of the same type as well) inside one 

configuration 

.   

This panel allows: 

 

• To input one new measure and configure it pressing New button; 

• To input one new measure from the LSI LASTEM sensors database, pressing Add button; 

• To modify the selected measure pressing Edit button; 

• To remove the selected measure pressing Remove button; 

• To sort the measures pressing Sort button; 
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• To import measure from the configuration of another instrument pressing Import button. 

 

The modification of each measure is made by means of following mask: 

 

 
 

 

The mask consists of under-sections of configuration; they have got different parameters according 

to the measure type (acquired or calculated).  

 

Warning 

When you configure some measures which aren’t connected to datalogger, you have to short-

circuit on terminal board the inputs 1-2-3-4 used by measures that have been configured but not 

connected, in order to obtain the right acquisition of all configured quantities.  

 

4.4.6.2. Modification/Input of measures from LSI LASTEM sensors library 

 

When you return to instrument configuration main mask, the key Add shows LSI LASTEM sensors 

library grouped by category: 
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Selecting the commercial code of the sensor, the program produces (for very associated measure) 

the suitable input channel, and if possible, it inputs the sensor inside the list of the measures. In case 

of serial measures it requires the input of the network address (Id protocol) of the sensor. 

 

 

4.4.6.3. Modification/Input of measures not included in the library starting from one 

pre-configured model  

 

Selecting Measures from panel General Parameters you can display the panel that includes the 

parameters for management of measures; the list shows the measures configured in the instrument.  

 

3-DOM gives you the possibility to start from pre-configured models in order to use one new sensor 

(relevant to probes not produced by LSI LASTEM or not included in the library). 3DOM offers this 

pre-configured models in the Other category: 

 

• Probe 0 ÷ 1V 

• Probe 0 ÷ 20mA 

• Probe 0.2 ÷ 1V 

• Probe 4 ÷ 20mA 

• Probe Pt100 

• Probe Pt100Ex 

• Probe TCE 

• Probe TCJ 

• Probe TCJDIN 

• Probe TCK 

• Probe TCS 

• Probe TCT 

• Probe Pt1000 

• Probe -39 ÷ 39mV 

• Probe -78 ÷ 78mV 

• Resistance 

• Counter 

• Frequency 

• Status ON/OFF  
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After the selection of suitable model to characteristics required by application, input the missing 

information following the instruction showed by program in bottom right box of window Sensors, 

where is displayed the sensors library 
 

 
 

In the following table are suggested the models to select according to sensor (also make reference to 

figures 4 and 5 of §3.1.2 “Connection of sensors and actuators” of manual INSTUM_00013): 
 

 

Sensor Type Recommended Models 

4 wires resistance 
Probe Pt100, Probe Pt100 Ex, 

Pt1000, Resistance 

2 wires resistance  Resistance 

Thermocouple According to type of thermocouple 

Voltage signal from externally powered sensor  
Probe 0 ÷ 1V, Probe 0.2 ÷ 1V, Probe -39 ÷ 

39mV, Probe -78 ÷ 78mV 

Voltage signal from 4 wires sensor powered (fixed or 

switched) from E-Log  

Probe 0 ÷ 1V, Probe 0.2 ÷ 1V, Probe -39 ÷ 

39mV, Probe -78 ÷ 78mV 

Voltage signal from 3 wires sensor powered (fixed or 

switched) from E-Log  

Probe 0 ÷ 1V, Probe 0.2 ÷ 1V, Probe -39 ÷ 

39mV, Probe -78 ÷ 78mV 

Current signal from externally powered sensor  
Probe 0 ÷ 20mA, Probe 4 ÷ 20mA  

(with 50 Ω resistance on B and C inputs) 

Current signal from 4 wires sensor powered (fixed or 

switched) from E-Log  
Probe 0 ÷ 20mA, Probe 4 ÷ 20mA  

(with 50 Ω resistance on B and C inputs) 

Current signal from 3 wires sensor powered (fixed or 

switched) from E-Log  
Probe 0 ÷ 20mA, Probe 4 ÷ 20mA  

(with 50 Ω resistance on B and C inputs) 

Current signal from 2 wires probe (powered from signal 

wires) 
Probe 0 ÷ 20mA, Probe 4 ÷ 20mA  

(with 50 Ω resistance on B and C inputs) 
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Digital status (ON/OFF)  Status ON/OFF 

Digital status or frequency signal  Status ON/OFF, Counter, Frequency 

Frequency signal from optoelectronics probe Frequency 

 

 

Also remember that: 

 

• To pass from current signal to voltage signal you must put in one resistance with value 50 Ω 

among the signal’s inputs in the datalogger’s terminal board; 

• Do not put over 1.2 Vdc for analogue inputs (E-Log: 1÷8; R-Log: 1÷4) when are used 

tension signals; if necessary provide with a voltage divider; 

• For digital inputs (E-Log: 9÷12; R-Log: 5) use any diode (example: type 1N4148, 

1N4007…) if signal is higher than 3 V dc; the anode of diode must be placed on clamp F of 

terminal board’s entrance and the cathode towards the sensor (see §3.1.2 “Sensors and 

actuators connection” figure 5 of E-Log – INSTUM_00013 manual); 

• The sensors that have status-output and produce voltage (i.e. they aren’t pure contacts 

opened/closed) but their voltage changes according to measured status, can be connected to 

the instrument by means of one diode; in this way the connection is always made correctly, 

apart from the output voltage (no divider required). the anode of diode must be placed on 

clamp F of terminal board’s entrance and the cathode towards the sensor;  

• In case of probes powered by the instrument check the actuator’s warm-up time, so that 

when the measure is acquired the probe is ready for correct operation; 

• For configuration of logical status, the instrument has been configured default so that: 
  

give logical status = 1 In case of short circuit or 0 V 

give logical status = 0 In case of opened contact or 3 V 
  
In order to invert the default logic there are two possibilities: 
 

- set “Status ON-OFF” from Measure properties and set-up: analogue Status ON = 1, 

analogue Status OFF = 0; logical status threshold = 0,5; 

- set “Parameters” from Measure properties and set-up: Internal Scale = 0÷1, User Scale = 

1÷0. 

 

4.4.6.4. Modification/Input of new  measures not included in the library  

 

If the library doesn’t include the needed measure, it’s possible to create one new measure following 

the instructions below: 

 

1. select Measures from panel General Parameters;  

2. select New using optional keys on right; 

3. from window “Measure property” select Disabled and then select Acquired Sensor 

from scrolling menu if you want configure a new one instrument; select Calculated 

Measure to input one measure calculated through E-Log application algorithms. Inside 

the same window it’s opened the sub-section General and other sub-sections called 

Parameters, Processing and Acquired Sensor too. 
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4. now modify the other fields referred to new measure: 

a. from page “General”: the name (not more than 11 characters), the compressed 

name (it’s automatically inputted by software using only the capital characters of 

complete name), the unit of measurement, trademark name (i.e. the sensor’s 

code), the measure type (select it, from scrolling menu, among temperature, 

humidity, radiation, pressure …) and the measure’s properties (select them 

among the properties proposed according to type of measure); 

b. from page “Parameters”: the unit of measurement, the accuracy and use of 

numerical parameters (select it, from scrolling menu, among scale parameters, 

calibration parameter, … or not used). If the user decides the input of numerical 

parameters, he has also to compile the fields that need the input of these 

numerical factors (internal scale, user scale …); see §4.4.6.5; 

c. from page “Elaboration” select one processing (only one in case of InfoGAP 

mode, more than one in case program hasn’t been setup in InfoGAP mode) 

among the suggested ones, and move it in the right column, like shown in the 

figure below; 
 

 
 

d. from page “Acquired Sensor” select the quantity type (among analogue, 

impulsive, digital status, inner, serial), the updating rate, the linearization type 
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and the starting time. Also select the measure’s electrical type and the channel’s 

number if quantity is analogue or impulsive or digital status; select the sensor’s 

protocol address and sensor’s measures index if the quantity is acquired by  E-

Log serial line.  

5. after the input of all measure’s properties select Ok. New measure is included into the 

list of configuration’s measures in the first free channel.   

 

4.4.6.5. Meaning of some configuration’s parameters 

 

Now it’s explained the meaning of some general parameters used for configuration of E-Log 

dataloggers. 

 

Precision 

(specific parameter for each configured measure; from Measure -> General Parameters -> 

Measure Property ->Parameters) 
 

It determines the number of decimal digits used for formulation of measure value. The user can use 

7 digits, comma included; for measures referred to environmental parameters can be used 2 decimal 

digits like default. So place the comma according to precision required for display of measures on 

acquirer’s display. 

 

Use of numerical parameters 

(specific parameter for each configured measure; from Measure -> General Parameters -> 

Measure Property ->Parameters) 
 

It determines if and how the measure uses the numerical parameters with mobile comma. These are 

the selections at configuration’s disposal: 
 

• Unused; 

• Scale Parameters: set-up the inner scale (sensor’s output) and the user scale (value required 

by user); i.e.: for sensor with signal 4÷20 mA which correspond to 0 and 1 m, with a 50Ω 

resistance across the terminals the signal becomes 200÷1000 mV, so set-up the inner scale 

with 200 and 1000 whereas the user scale with 0 and 1;      

• Scale Parameters for wind direction measurement: set-up for measures of wind direction 

and so the transformation of resistive signal into angular value; the value of direction should 

not be in error when the potentiometer is interrupted in North zone; 

• Scale Parameters for humidity measurement: set-up to avoid error signal in case of value 

over (up to 5% max) 100% humidity;  

• Calibration Factor: it’s usually used for global radiometers for correction of positive 

signals, whereas the negative signals are set at zero; input value like mV; 

For configuration of digital status or counters input the result you got dividing the unit of 

measurement by the sensor’s restitution value (i.e.: for one rain gauge c/w tipping bucket of 

0.2 mm capacity, input value 5 that is number of impulses for one unit of measurement; 

actually 0.2 x 5 = 1 mm; 5 “tipping buckets” of  0.2 mm are needed to obtain 1 mm rainfall).  

• Calibration Factors for negative and positive signal: it’s usually used for net radiometers 

for correction of positive and negative signals; input value like mV; 

• Analog probe status levels: set-up limits of logical signal  ON/OFF and the value of 

overcoming threshold; use for analogue signals; 

• Scale Parameters for calculation of the difference among acquisitions: set-up parameters of 

inner scale and user scale; the scale parameters of totalizators with analogue output are used 
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for calculation of difference among consecutive acquisitions; they calculate the totalizator’s 

increase during acquisition rate; 

• User scale limits: set parameters for user scale; be used for calculated measures. 

o Total count: it requires setting the Start and End scale parameters in order to obtain 

the counting limit and the return value when the count limit exceed the maximum;   

o Delta with previous value: is the inverse of total count; it also requires the same 

input parameters. 

 

4.4.6.6. Importing measures from another configuration 

 

This feature, available from version 3.6.0.0 of the program can import as serial measures the 

measures contained in the configuration of another instrument also of different types, for example, 

you can import in the configuration of an E-Log instrument the measures configured in a R-Log 

instrument 

 

WARNING: 

The purpose of this function is to facilitate the setup of a Master instrument using measures 

configured in Slave instruments. To configure an instrument in a similar way to another 

instrument do NOT use this procedure but create a custom template (see § 4.4.3) 

 

To start to import measures, press the Import button in the panel with the list of the measures: 

before you start the import process the program will sort the measures already configured. The 

procedure displays all instruments and requires the user to select the instrument and the 

configuration that contains the measures to be imported: 

 

 
 

After completing the procedure all the measures included in the chosen configuration will be 

imported in the current configuration. Please note that: 
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• all measures are imported as a serial measures; 

• the characteristics of the measures that are imported are the name, the factory name, the unit 

of measurement, the precision, the type of measure and its properties, the elaborations types: 

other parameters must be configured manually; 

• protocol address of the sensor is assigned based on the second serial port configured in the 

instrument by which you are importing the measures; 

• measures are imported in the same order of the origin configuration of origin; 

• if you change the source configuration is necessary to remove all imported measures and 

repeat the procedure. 

 

4.4.6.7. Modification of serial communication parameters  

 

Through 3DOM software you can change the serial communication parameters for both serial ports 

of instrument. The serial port number 1 manages the Native protocol; it is possible modify these 

parameters: Instrument network address (usually set to 1), Message transmission repetition, 

(Communication) speed, Instantaneous values automatic transmission rate (for cordless and radio 

transmission), Flow control type and Modem Type (None, GSM, GPRS).  

Select Serial Communication Port 1 from panel General Parameters to display panel which 

includes the parameters for flow control. Now select the required option from scrolling menu Flow 

Control Type: 

• None: use for connections to computer-equipments that don’t need any flow control; 

• only RTS: required for use of cordless LSI LASTEM DEC211 and DEC301 

communicators; this is manufacturer’s setup; 

• RTS/CTS: use if E-Log is connected to DCE computer-equipment through adapter null-

modem that needs this flow control. 
 

The serial port number 2 operates with several protocols that fit the types of sensors connected to it; 

it’s possible manage these protocols: Native, CISS Probe, TTY, Modbus, Gill anemometer, Giletta 

ice probe GIL-D-ICE, Aeroqual analyzer, Hydrolab, Lufft UMB sensor, Climatronics sensor.  

Select the protocol of interest and modify the configuration parameters that are activated. For 

ELO505, ELO515 and ELO516 models, the serial port number 2 is internally (not externally 

visible) occupied by ZigBee radio; in this case you can change only radio communication 

parameters. 
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(Serial port 2 configuration: on the right the configuration for datalogger with Zigbee Radio) 

4.4.6.8. Modify of others configuration parameters 

 

In the configuration you can also change these parameters:  

• General parameters -> Standard: parameters set to a fixed numerical value and used for 

calculated measures or compensations;  
 

 
 

• General parameters -> Elaboration : elaboration rate of measures; it is allowed an unique 

elaboration rate for all the measures; remember to set a rate higher than the update rate of 

sensors; 

• General parameters -> Linear parameters: parameters of polynomial functions (not 

included in General parameters -> Measures -> Acquired sensor -> Linearization type) that 

can be used for linearization of non-linear parameters; can be used three type of 

linearization: “CT_GF” for thermocouple, “CT_ForceZeroIfZero” for polynomial where 

you must force to zero if the measure is zero, “CT_Nothing” for the other cases. 

• Actuators-> Logics: selection of actuation logic type among: eolic alarm, evaporimeter 

filling logic, start precipitation alarm, flood alarm, threshold value compare, timer, snow 

level alarm, system error (see INSTUM_00351 manual for technical features on actuators); 

after the choice of logic, set the required parameters. 
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• Actuators -> Actuators: assignment of actuation logics previously chosen to datalogger 

outputs (E-Log has got 7 actuators). 

   

4.4.7. Configuration of AlphaLog, Pluvi-ONE 

 

For configuration details of these instruments, refer to the specific online guides accessible from 

the ? menu. 

 

The window to modify the configuration of these types of instrument has an appearance similar to 

this: 
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AlphaLog v2-8 

 

Each element of the Items list corresponds to a section of the configuration parameters. Depending 

on the type of instrument and its firmware version, some of these elements may not be present. 

 

• Registry: contains registry information of the instrument and site information (longitude, 

latitude, time zone…). 

• System: contains settings related to the operating mode of the instrument. 

• Connectivity: contains settings related to the instrument connectivity to the external word, 

especially which concern Internet operations (Ethernet, Wi-Fi, PPP, DNS, FTP, SMTP, 

NTP, MQTT…). 

• Serial Ports: contains settings related to the instrument serial communications ports (local 

and remote) 

• Input Types: contains settings related to the input types; each input types groups one or more 

measurements as coherent entities having common properties (Tipping bucker rain gauge, 

Analog inputs, Lightning sensor, Thermo-hygrometer RTR, Thermo-hygrometer SNS, 

Atmospheric pressure, Modbus RTU Master…) 

• Measures: contains settings related to the measures programmed in the instrument.  

• Elaboration Parameters: contains settings related to the statistical elaboration of sampled 

and calculated data from measures. 

• Validators: set the data validation configuration, if supported by the instrument. 

• Logics: contains settings related to the logics used by the instrument to verify possible 

warning or alarm conditions. 

• Actions: contains settings related to the actions the instrument can executes when ore or 

more logics change their states. 

• Calculation Modules: set options for the various extensions that may be available in the 

instrument. 



LSI LASTEM 3DOM – User Manual 

 

33 

 

When checking or saving the configuration, you are asked whether to check the connection 

parameters: it is ALWAYS recommended to check the connection parameters. 

 

For a detailed description of the various sections, see the specific instrument manual. 

4.4.7.1. Measures 

 

The Measures section shows the list of configured measures grouped according to the Input Type to 

which they are connected: 

 

 
 

To add a new measure select th <Add> button: 
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It is possible to add a new empty measure, create a new calculated measure or insert a measure from 

the list of preconfigured measures available in the LSI LASTEM sensor library. 

If you create a new empty measure, you must select the Input Type to which the measure is 

associated: 
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If the Input Type is not available in the list it is necessary to exit the measure edit window, select the 

item Input Types in the instrument configuration window and add and configure the Input Type  

required. 

 

In the General tab you can set the general parameters of the measure (name, unit of measure, type 

and properties of the measure ...); in the Sampling tab it is possible to set the sampling parameters 

of the measure; in the Elaborations tab it is possible to associate the measure with one or more of 

the already configured elaboration rates or add a new one. 

 

4.4.7.2. Sending data to the LSI Lastem CUBE cloud 

 

If instrument supports this feature you can configure the instrument to send data to the cloud. 

Open the Connectivity item, select the LSI LASTEM CUBE network protocol and configure the 

present parameters: 
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IMPORTANT: 

In the configuration of the individual measures it is necessary to configure the Measure Key 

parameter of the measure present in the General section of the configuration window. 

4.4.8. Send the configuration to the instrument 

 

For the sending of one configuration to the instrument follow these instructions: select the required 

configuration and then the menu Configuration->Send or the key Send on the keys bar 

Configuration or the menu Upload Configuration on the selected configuration. 

 

The program processes following operations: 

 

1. In case of one current configuration it verifies the communication parameters between the 

instrument and the current configuration (different parameters doesn’t allow the 

communication with the data logger);   

2. It verifies that: the instrument and the new configuration must have the same serial number; 

at the opposite it stops the process;  

3. If the local calibration file is more recent than the file included into the instrument, it 

updates also the calibration;  

4. At the end of this operation the sent configuration becomes the current configuration of the 

instrument; it updates the personal date in the panel Properties and the communication 

parameters.  

 

For the AlphaLog or Pluvi-ONE class instruments, it is first required to select the communication 

mode (§ Errore. L'origine riferimento non è stata trovata.) 
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4.4.9. Receive one configuration from the instrument  

 

To receive the configuration saved into an instrument arrange as follow: select the instrument from 

the left panel of the program main window, then select the  menu Configuration->Download or the 

key Download on the keys bar Configuration or the menu Download Configuration on the selected 

instrument; if needed, it updates the calibration file of the PC too.  

 

At the end of the configuration’s reception, the user selects the name for new configuration, and this 

one will be included into the suitable list like current configuration. 

 

For the AlphaLog or Pluvi-ONE class instruments, it is first required to select the communication 

mode (§ Errore. L'origine riferimento non è stata trovata.) 

4.4.10. Configurations’ import and export 

 

Selecting the menu Instrument -> Export or the contextual menu Export, it’s possible to export all 

configuration files of the selected instrument (included the calibration and communication’s 

parameters) into one .zip format file. These functions can be used both for the transfer of 

configurations among different PCs and for the sending of configurations to the LSI LASTEM 

Customers Service (in case of wrong operation of the software and / or of the instrument). 

 

 
 

The export window allows the selection of the files for their exportation.  

 

At the same mode, selecting the menu Instrument -> Import or the contextual menu Import, it’s 

possible to import the configurations (included into the file) from a .zip format file (set-up suitable 

for exportation). 

The import window displays all the configurations of the file (and advises if already included). 

Please consider that: 

 

• The file’s configuration overwrites the configuration imported with the same name of the 

local one; 

• The calibration file is shown only if more recent than the local one.   



LSI LASTEM 3DOM – User Manual 

 

38 

 

Warning 

The overwritten file isn’t able to communicate with the instrument, if: the new values are 

different from the old ones, and the instrument has been configured with the old values. 

 

 

4.4.11. Modify the name and the description 

 

The user can modify the name and the description of the selected instrument, selecting the menu 

Instrument -> Change description and user serial number. Max length of the new name (or 

number) is 15 characters. It’s used to sort the instruments’ list displayed in the main window, 

selecting the View -> Order by user serial number. It’s possible to modify the display of the 

instruments list and sort it according to the description selecting View -> Order by description. 

  

Warning 

The new name is sent to the instrument with the first valid configuration (in order to avoid the 

cancellation of the instruments’ data). The name already modified, but not yet sent to the 

instrument, is shown with the symbol “!”, while the Registry windows shows the user name 

actually in the instrument with the note (not updated). 

The E-Log 1.x versions allow names with maximum 8 characters. 
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4.5. Basic communications 
 

The program manages: configurations’ input and output, instantaneous data’s display (ref §4.6.1),  

processed data’s download (ref. §4.6.3), and basis communications with the instrument: 

 

• Display of the instrument’s personal data; 

• Display of the operating statistics;  

• Check of the operating condition. 

 

 

Note 

Not all instruments kind does support the information here indicated; some instruments may 

show less information or not show anything. 

 

4.5.1. Instrument’s personal information 

 

To display the personal data of the selected instrument, select the menu Communication -> Registry 

or the key Registry on the keys bar Communication or the menu Registry. 

 

 
 

The information displayed depends on the type and version of the instrument. 

4.5.2. Operating statistics 

 

To display the operating statistics of the selected instrument, select the menu Communication-> 

Statistics or the key Statistics on the keys bar Communication or the menu Statistics. 

 

The information and actions possible in this window depend on the version and type of the 

instrument: 
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E-Log 
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AlphaLog 

 

4.5.3. Operating state 

 

To display the operating state of the selected instrument, select the menu Communication-> State or 

the key State on the keys bar Communication or the menu State. 

 

The information displayed depends on the type and version of the instrument. 
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E-Log 
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AlphaLog 
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4.6. Transfer of the surveyed data  

4.6.1. Display of the instantaneous data  

 

To display the instantaneous data of the selected instrument, select the menu Communication-> 

Instantaneous values or the key Instantaneous values on the keys bar Communication or the menu 

Instantaneous values. 

 

The visualization of the instantaneous data of AlphaLog and Pluvi-ONE instruments is only 

possible using the direct connection to the instrument through the SSH protocol. 

4.6.2. Configuration of the data-storage modes  

 

To download the data from the instruments’ memory, the user has to configure the data-storage 

modes; selecting the menu Options  ->Data storage configuration or the key Data storage or the 

menu Data storage and are shown in the Data storage configuration windows. 

 

The program has got different modes for data save:  

 

1. Save on text ASCII file; 

2. Save on binary file (more compressed) 

3. Save on database Gidas (from SQL Server 2005), which can be used by GidasViewer 

program for the display of the downloaded data. 

4. Save to FTPXlogFile for format compatible with data sent by X-Log instruments directly to 

an FTP area. 

 

For specific application could be available others modes for data save. 

 

The save configuration window allows:  

 

• To choose the data storage  for data save; 

• To configure the available data storage. 
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To configure one data storage:  double click it from the list to show the configuration window. 

4.6.2.1. Store the data on text file  

 

This window is used to configure the text file storage: 
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To enable the text files storage, select the checkbox “Check to activate data storage”. 

 

Format options, it is possible set-up: 

 

• Decimal numbers separator (to display the real numbers); 

• Decimal places for each processed number; 

• Number of characters to display each number; 

• Data columns separator, (select it from the list or input a new one); 

• Date time format: it is possible to select one of these options: 

a. Local: uses computer local settings; 

b. ISO 8601: uses ISO 8601 format (year-month-dayThours:minutes:seconds); 

c. Year/Month/Day, Month/Day/Year, Day/Month/Year: uses this sort order to format 

date; to format time always uses local separator; 
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d. Custom: user can insert a custom format using these characters: yyyy=year, 

MM=month, dd=day, HH=hour, mm=minutes, ss=seconds 

 

General options, it’s possible to set-up: 

 

• The mode for the display of the file header; selecting the checkbox Store informative 

headers it inputs the header inside the data file (this header describes the structure of the 

available measures and processing 

• The writing mode on file: selecting Append data on the same file every download writes the 

data at the end (queue) of the file; ); if this option is enabled you can also select the option 

Create new file every day to create e new file every day. 

WARNING: the date used to decide if it is necessary to create a new file is the download 

date and not the elaborated values date.  

 

Folder options, it’s possible set-up: 

 

• The main folder where save the files; 

• Select Append serial number, to save the files in different folders adding serial number to 

the main folder, select Append user name, to save the files in different folders adding 

instrument user name to the main folder, 

 

File options, to generate the name of the file where downloaded values are saved select the button 

 to open the Definition of the file name windows; 

 

 
 

In this window you can specify the file extension and build the file name using a series of TAG to 

dynamically generate it. The available TAGS are: 
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• %SN% : this TAG inserts in the name of the file the serial number of the datalogger 

• %UN% : this TAG inserts in the name of the file the user defined name of the datalogger 

• %FT% : this TAG inserts in the name of the file the type of the downloaded data (values are 

Elab for elaborated values, Inst for instantaneous values, Status for statistical values) 

• %YMD%, %MDY%, %DMY% : these TAGS insert in the name of the file the file creation 

date using four digits to represent year and two digits to represent month and day. The 

difference between these TAGS are elements order (Y=year, M=month, D=day) 

• %HMS% : this TAG inserts in the name of the file the file creation time using the format 

hours (from 00 to 23) minutes (from 00 to 59) seconds (from 00 to 59). 

• %CFG%; this TAG inserts in the name of the file the configuration date of the datalogger in 

the format yyyyMMddHHmmss. 

 

Every TAG is begins and ends with the characters “%” and is case sensitive. The red label shows 

the resulting file name assuming an instrument with Serial Number=12345678 and a User Name = 

meteo1. 

 

Warning 

If the user doesn’t select the option “Append data on the same file” every instrument data save 

sets-up one new data file.  

If the user selects the option “Append data on the same file”, the name of the file should NOT  

include date or time TAGS; if the user selects the option “Append data on the same file” AND the 

option “Create a new file every day” the name of the file MUST contain a date TAG and should 

NOT contain a time TAG. 

 

Warning 

If the datalogger supports several elaboration bases (such as Pluvi-ONE), the suffix "_Bnn" will 

be added to the file name where "nn" represents the index of the elaboration base.  

4.6.2.2. Storage the data on Gidas database 

 

Warning 

To storage the data on Gidas database arrange as follow: 
 

• Install GidasViewer program which install Gidas database; Gidas database requires  SQL 

Server 2005 or superior: if there is not an instance of SQL Server the installer program 

installs the Express edition free for the end user. It is required a specific license file for 

each instrument to enable Gidas database as storage for the datalogger downloaded data. 

 

To get more information about Gidas database see GidasViewer documentation. 

This is the window that configures the storage on Gidas database: 
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To enable the storage select the checkbox Check to activate data storage. The list shows the status 

of current connection. You can change it by pressing the Select button that opens the configuration 

windows of the Gidas database connection. 
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This window shows the Gidas data source in use and allows the change of it. To change it check an 

item of the data source connection list or press the Add button to add a new one; use the Test button 

to test selected connection availability. You can also change the query time out of the data source in 

use (this number can be increased if a poor performance database server is used). 

 

The list of the available data sources contains the list of all the data sources inserted by the user, 

therefore initially it is empty. This list also shows the data source used by the various LSI-Lastem 

programs.  

 

The Remove button  removes a data source from the list: this does not change the configuration of 

programs that use the deleted data source, which will continue anyway to use it.  

 

To add a new data source connection press the Add button of the previous windows to show the Add 

New Data Source window. 

 

 
 

Specify the instance of SQL Server it has to connect to and check connection through key .  

The list shows the only instances of SQL Server 2005 which have been identified in local computer. 

The name of a SQL Server 2005 instance has following format: 

 

servername\instance name 

 

where nomeserver is the network name of the computer where SQL Server has been installed, in 

case of local instances it’s possible use whether name of the computer or word (local) or only the 

point (.)  

 

In this window it is also possible to set the timeout for the data queries sent to the database. 

 

WARNING 
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Use the Windows authentication if the connection verification fails. If the instance of SQL Server 

is in the network and the Windows authentication fails, contact your database administrator. 

4.6.2.3. Store the data on binary file 

 

Storing data on a binary file is used to preserve data in a compact mode that allows the subsequent 

recovery using 3DOM program. This is the window that configures the storage on a binary file: 

 

 
 

The user must select the archive folder where to save the binary files; the file name is automatically 

assigned as follows: 

 
serialnumber_startdate_enddate.bin 

where: 

• serialnumber: instrument serial number; 

• startdate: start date of the downloaded data; 

• enddate: end date of the downloaded data. 

 

This file is a zip file containing the data processed and the configuration of the instrument, 

information necessary to restore the data. 

 

This option is not allowed for AlphaLog and Pluvi-ONE instruments. 

4.6.2.4. Restore the data from a binary file 

To restore data in a binary file (stored as described in 4.6.2.3) select the menu File → Import binary 

data. Follow the wizard by selecting the file containing the data to be imported. 

 

Warning: 

The data contained in the file will be saved in all data storage configured in 3DOM (excluding 

binary support); to change data storage destination of the data in binary file, close the procedure, 

change the data storage and restart the procedure. 
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4.6.3. Transfer and save of the processed data  

 

To transfer the processed data from selected instrument to PC, select the menu Communication-> 

Elaborated data or the key Elaborated data on the keys bar Communication or the menu 

Elaborated data. It displays the following data download window: 

 

 
 

The connection between the program and the selected instrument enables the key Download; then  

continue as follow: 

 

1. Select the starting date for data download; in case of previous data downloads, the check 

proposes the date of the last download; 

2. Select the box Show data preview if the user want display the data before their save into 

selected and configured files; 

3. Press key Download to start the data download and the save of the selected and configured 

files. 

 

If selected the option Show data preview, at the end of data download, and before their save into the 

selected files, it displays the downloaded data window: 
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Press key Cancel to close the window and DO NOT save the data, press key  Save Data  to save the 

data into the selected files. 

 

The download and the save of the processed data (included into the instrument) updates the 

Downloaded elaborated data status of the program’s main window.  

 

4.6.3.1. Transfer and save of the processed data for AlphaLog and Pluvi-ONE 

 

Before starting the transfer and saving of the processed data, the program will show the Select file 

source window: 
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It is possible to: 

• Connect directly to the instrument via the SSH protocol. 

• Download files from an FTP area of your choice from those configured in the tool. 

• Select a local or network folder that contains the files with the processed data generated by 

the tool. 

 

Once the file source has been chosen, the program downloads all the files that contain more recent 

data than the date of the request and proceeds to save the data on the selected storage. 

The AlphaLog and Pluvi-ONE instruments only support saving to text files and Gidas database 

(SQL Server). The names of the text files contain at the end the suffix _Bnn where nn represents the 

index of the elaborated base (§ 4.6.2.1) 
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This picture shows the page with the last uploaded files and values. It’s possible to download these 

files that are in the original format sent by the instrument. 

 

 

4.7. Communication by modem (E-Log, R/M-Log,S-

Log) 
 

If the instrument has been configured for communication by modem, at communication’s start it 

display as follow: 

 
 

To start the connection press the key Connect. If selected the checkbox Hang up at the end of the 

communication the 3DOM program disconnects the communication automatically. At the opposite 

it’s connected for further needs. In this case:   

 

• The connected modem condition is shown in the state bar of the main window; 



LSI LASTEM 3DOM – User Manual 

 

56 

• In the keys bar of the main window is displayed the key for disconnection  

 

Warning 

When the modem is connected, the communication with other instruments isn’t possible. 

 

 

4.8. Error’s codes display (E-Log, R/M-Log,S-Log, 

ALIEM) 
 

Selecting the menu View -> Errors Code Visualizer the user can read a brief description of the 

error’s codes (in hexadecimal code). 
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5. Find Instrument Utility  
 

To activate the Find Instrument Utility select menu Instrument → Find Instrument. Depending on 

the selected instrument type the program will show the correct utility. 

 

 

5.1. Instruments E-Log, R/M-Log, S-Log, ALIEM 
 
 

 
 

Check serial ports, bit rates and select instrument network address, used to find instruments 

connected to serial ports. This utility is useful when instrument has not monitor or there are doubts 

on selected bit rates. 

 

5.2. Instruments AlphaLog e Pluvi-ONE 
 

This utility program allows you to check for instruments connected to the local network: 
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The utility takes about 30 seconds to execute the search. 
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6. Auto Updates 
 

Use menu Help → Check for updates to run the program LSI Update Center which verifies the 

availability of the new versions of the LSI LASTEM programs installed in the computer. 

 

The LSI Update Center program is one of the components of the LSI Support Center program 

which can directly be installed by the CD of the products LSI LASTEM or from the CD of the 

licenses files or downloading the installer file from the site FTP of the LSI LASTEM. The LSI 

Support Center also contains the component which manages the licenses of the programs installed 

on the local computer (§7).  

 

6.1.1. Installation of the program from the site FTP 

 

If the program LSI Update Center is not installed in the local computer you can download the 

installation file from the LSI LASTEM FTP site. At the end of the downloading the installation will 

automatically starts; at the end of the installation  the program will be started. 

 

6.1.2. Program use 

 

The LSI Update Center program is composed from two modules: 

 

• the program LSI Update Center Monitor that is started in automatic with the operating 

system and that verify periodically the availability of updating for all the LSI LASTEM 

programs installed in the computer. 

• The program LSI Update Center that it shows the state of the available updating and, if the 

case, discharge from the LSI LASTEM web site the files of installation and starts the 

installation of the upgrade. 

 

The program LSI Update Center shows the state of the LSI LASTEM programs installed in the 

local computer: 
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For every program the installed current version and the last available version is visualized. A 

program can be in one of these states: 

• up to date; 

• not updatable: a new version exists but the product is not updatable; 

• updatable: double click the product to update on the list to start download the installer 

file. 

 

Selecting Information it is possible to visualize a web page that contains the list of the changes of 

all the versions of the selected program. 

 

Through the button Search is adjourned the search of the updating and through the button Settings 

are modified the connection properties, if a proxy is used, and the temporal interval used by the 

monitor for the automatic search of the updating. 

 

You keeps in mind that when this program is started by the menu Start → Programs of Windows or 

from the contextual menu of the monitor the program visualizes the results of the last automatic 

search affected by the automatic monitor visualizing the date of the search. To adjourn the data 

press the button Search. 
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7. The Licenses Manager program 
 

Use menu Options → Licenses Manager to run the program LSI License Center which manages the 

LSI programs licenses installed on the local computer. 

 

The 3DOM program needs licenses only to save data on the Gidas database. 

 

The LSI License Center program is one of the components of the LSI Support Center program 

which can directly be installed by the CD of the products LSI LASTEM or from the CD of the 

licenses files or downloading the installer file from the site FTP of the LSI LASTEM. the LSI 

Support Center also contains the component that verifies the availability of the new versions of the 

LSI LASTEM programs installed in the computer (§0). 

 

7.1.1.1. Installation of the program from the site FTP 

If the program of the management of the licenses is not installed in the local computer you can 

download the installation file from the LSI LASTEM FTP site. At the end of the downloading the 

installation will automatically starts; at the end of the installation the program will be started. 

 

7.1.1.2. Program use 

 

 
 

The program visualizes all the installed licenses in the computer divided for single programs or 

single tools. Through this program it is possible:  

• to export the selected licenses in an archive file; 

• to import an archive licenses file in the local computer; 

• to produce a simple text file report  with the list of the installed licenses in the computer; 

• to directly download the licenses archives from the LSI LASTEM site; 

 

The licenses archive is constituted by an only file zip of extension .lsilic: this is the format with 

which the licenses are distributed by LSI LASTEM. 
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Every licenses archive can be downloaded from the LSI LASTEM site inserting the License Code 

supplied by LSI LASTEM with the purchase of the programs. 

 

 
 

 

Through the Settings button it is possible to set the parameters of the Internet communication in the 

case it is present a server proxy. 

 


